Capture

WordPress rolled out a new version of our loved Content Management System, WordPress 3.7. codenamed “count basie“. It’s a somewhat important release where most of the changes are under the hood, not really visible on your website frontend or backend.

Should I upgrade to WordPress 3.7?

You should, this new version fixes security issues with previous versions and implements a new updater where wordpress can quickly deploy security fixes that can / will affect future versions of wordpress.

Before upgrading, you should check all your plugins compatibility, getting in touch with the developer or checking the plugin page in wordpress website would be a good idea. Regarding TechGasp plugins, you are safe to go.

How do I turn these wordpress automatic updates off?

Just edit your wordpress wp-config.php and add the following line:

define( 'WP_AUTO_UPDATE_CORE', false );

Whats new in WordPress 3.7?

  • Background Updates
    • Automatic updates for maintenance and security updates.
    • Daily updates for developers using nightly builds.
  • Stronger Password Meter
    • New password meter to encourage users to choose stronger passwords.
  • Improved Search
    • More relevant search results.
  • Better Global Support
    • Localized versions will receive faster and more complete translations.
    • Background updates will include translations

What about Techgasp Pugins?

No problem, you have permission to lift off. All TechGasp plugins are fully compatible with wordpress 3.7. This website is already upgraded and running version 3.7, you can check all plugins and demos.